Reaper for Post Production

From CockosWiki

Jump to: navigation, search

Main Page > REAPER Documentation

Contents

Introduction

Basic Editing Capabilities

Trim, split, fading, cut, copy, paste are all there. At v3.0 its way of making selections is a little unorthodox, but it works for most things.

Items

The basic unit in Reaper is the item.

Each item has zones that provide different functions for the user to execute when clicking the left or right mouse button. One item or all selected items can be trimmed, faded, time-compressed/-expanded or have their item volume changed. Take a look at this image for an overview of what the left mouse button can do to items: Media:http://shup.com/Shup/146633/reaper25830betalayerswh.png

The right mouse button clicked by itself on a static mouse cursor will call up the context sensitive menu. If your mouse cursor is above an item, you will see almost all commands that can affect an item listed.


Selecting with the mouse buttons

As soon as you right-click and move the mouse cursor, you draw a bounding box. When the right mouse button is released, all items that this bounding box touches will be selected. Hold the ALT key to make a time selection at the same time. These two behaviors can be swapped with a preference setting, which you will find in the preferences page Editing Behavior/Mouse at the bottom. It is called Select both time and items when using right click marquee (alt toggles).

This becomes very important for any editing activity that doesn't involve complete items. Most of Reapers commands only work on selected items, and thus this combination of item selection and time selection is vital.

A time selection is an area that spans all tracks and has a starting time and an end time, as well as a resulting length. These three numbers are visible on the far right of the transport section, which is located at the bottom of the arrangement area by default.

The commands Cut, Copy and Paste only apply to complete items. If you want to affect only part of an item, which can only be determined with a time selection and an item selection, you need to use other commands for that. Copy selected area of selected items and Cut selected area of selected items are these commands. There is no delete command for removing a selected area of selected items.


Selecting without the mouse buttons

Reaper features a command, or rather an action as it's called, to select an item underneath the mouse cursor. There is also a command to add to your existing item selection. Since actions can be combined in to macros, or what Reaper calls custom actions, you can pretty much apply any command to where your mouse cursor is.

One illustration of this powerfull set of commands can help you editing, is splitting items while taking the configured grid in to account. You can tell Reaper to select the item underneath your mouse cursor, place the edit cursor where the mouse cursor is while respecting the grid(or not), and split that item at the edit cursor. The result is a mouse-over split command.


Standard Editing Commands

As mentioned above, there are commands to affect items and the area of selected items covered by a time selection. A number of split commands are available as well.

Split items at cursor , Split items at prior zero crossing and Split items at time selection.

The reason for the first and third command not being the same, is that the time selection is independant of the edit cursor, which you can place anywhere at any time without affecting the time selection.

Trim commands are available and also only work on selected items, which left-clicking on an item does.


Making Time Selections

Apart from the lasso/marquee method that involves the right mouse button, you can also left-click and drag in to an empty area of the arrangement area. The left and right boundaries of a time selection can be changed by left-click and dragging them, if your mouse cursor is in an empty area or an envelope lane.

If the loop and time selection are linked (Options/Loop points linked to time selection), the time selection can be changed or created by dragging the loop points at the top of the arrangement area or left click and dragging in the same area.

Setting Up Your Own Keyboard Map

Much of the elements of the Graphical User Interface of Reaper do nothing but trigger actions, which the user can also tie to as many keyboard commands or midi messages as he/she desires. This is achieved in the Actions Window, where you set up, import and export your keymaps. You can also run the actions from that window one by one if you wish.

Actions can be combined in to macros. A macro can consist of one action or more, even other macros. Including other macros only copies the macros actions in to your newly created macro. They can be named.

The top-most entry in the Actions menu of Reaper "Show action list", or its default shortcut '?' will lead you to the Actions Window. This can be kept open at all times, if one wishes to do so.

Available actions, including any multi-action macros you set up, are available in the action list. The list can be filtered by entering text in to the box above that list. Whether or not a shortcut is tied to a particular function can be determined by clicking on the Find Shorcut button.

Once an action is selected in the list, a key from the keyboard, or a midi message including midi notes, can be attached to that command by clicking on the Add button in the bottom left of the Actions Window, as well as removed with the delete button.


Timeline, Grid and Snap Setup

Grid and Snap settings are combined in to one window and are accessible via right-clicking on the Snap or Grid icon in the top left of the arrangement view, or via the Options menu under "Snap/Grid Settings". The standard shortcut is ALT+L on Windows.

The Timecode type can be setup by either right-clicking on the timeline above the arrangement area or accessing the project settings tab of the Project Settings window. That Project Settings window can be called up via the File menu, the default shortcut ALT+Enter(Windows) or the Project Settings icon on the top left of the arrangement area. It's the little wrench icon.

Frame-sized grids can be made by setting the timeline the BPM time in the transport section below the arrangement view to one value, and the grid line spacing to another value. These value pairs are as follows for different timecode grids :

FPS BPM Grid Line Spacing
23.976 60 1.001/24
29.97 60 1.001/30
24 60 1/24
25 60 1/25

Note that the grid size for 29.97 df (drop-frame) and 29.97 (non-drop) is the same. It is the counting/numbering of the frames that changes.

Timecode, chasing and sending

Chasing Incoming Timecode

Most of the information you need on Reaper capabilities are spelled out from section 21.6 Syncing to an external device onwards in the Reaper manual. It includes syncing Reaper to external MTC , LTC , SPP(Song Position Pointer) and ASIO positioning protocol.

Sending Timecode

Sending MTC can happen in three ways.

First, you can set up a MIDI port to send MTC in the Preferences page Midi Devices, which is further detailed on the same section of the manual as mentioned above.

Second you can place a SMPTE LTC/MTC Timecode Generator item in the timeline. This command can be found in the Insert menu. You can configure the item, which can be trimmed out as far as one wants, by accessing the source properties of the item, accessible in the context menu of item or via the default shortcut CTRL+F2(Windows).

Third, you can use the JS plugin vVIMTC (virtual Vertical Interleave MIDI Timecode Generator) which you can pick up in this thread. http://forum.cockos.com/showthread.php?t=43606&highlight=mtc

That JS plugin will send a highly configurable MTC timecode out even when your transport is stopped, making it rather handy for external video players.

Setting up Video

External Video

Setting up Reaper for controlling external video players can be done by sending out MTC and/or LTC timecode. See the section above for details on sending timecode. http://www.cockos.com/wiki/index.php/Reaper_for_Post_Production#Sending_Timecode

Internal Video

Go here to read about Reapers improved video support: http://cockos.com/wiki/index.php/Video_Support


Below the video support for Reaper without new improved support of FFMPeg is detailed.

Drag and drop a video file in to the timeline, on to any track. Reaper can playback anything the system can play. On Windows that means anything for which a codec is installed.

Supported codec and containers are AVI (Xvid/Divx/Indeo/DV/...) and Quicktime MOV (everything).

Recommended container/codecs combinations are

Container Codec Comments
AVI XVid The Iframe distance can be setup during encoding making this codec fairly useful for seeking quickly.
AVI DivX The Iframe distance can be setup during encoding making this codec fairly useful for seeking quickly.
MOV PhotoJPeg Fast seeking due to GOP-less compression. Example: 512x288 @ 25fps, 23 minutes, no audio, Quality HIGH results in about 1 GB of data
MOV h.264 A little slow seeking backwards but solid forward sync, good picture and small file sizes.

Editing Dialog

Setting up ADR, Foley & VO cues

Reaper can insert and name empty item as place holders for ADR lines, foley cues and VO. This is useful for recording in recording in "Autopunch selected items" mode.



Extensions and Companion Programs

SWS Extension

Adds a great deal of functionality to Reaper. The Xenakios extension has been merged with this.

Versions available are : Windows (32bit/64bit) and MacOSX (Universal Binary)

http://www.standingwaterstudios.com

Shanes Autorender

Update 2011, March 31st: The basic capabilities of this program are now part of the SWS Extension 2.0 beta, which thus includes OSX support!!!

The updated version requires Reaper v4.0 alpha60 or higher, depending on API changes so get the latest Reaper alpha/beta/pre version as well via the Pre-Release Forum.

Download of the newest extension betas https://code.google.com/p/sws-extension/downloads/list

Download of the newest Reaper alpha/beta/pre http://forum.cockos.com/showthread.php?t=22836


Regions in Reaper are markers that extend from one timecode position and end at another. They are created with the default shortcut SHIFT+R. They appear as green bars in a small track strip above the marker track strip. They can be named by SHIFT+double-click on the region strip, and by double-clicking in the region name in the Marker List of the SWS Extension.

Shanes Autorender application is a compiled AHK script, that renders each region to a file named with the regions name. It features a multitude of additional options to help folks. Remember that after you press GO in the Autorender window, you can press escape as the render dialog appears to change the settings of the renders.

http://code.google.com/p/autorender/

Feature requests can be posted here http://forum.cockos.com/showthread.php?t=16207



AATranslator (session translation tool for Windows)

AATranslator v4 and up can now read and convert session from

  • Protools 5 (pt5)
  • Protools 7, 8 and 9 (ptf)
  • CMX
  • Tracktion (.tracktion)

convert sesson to and from the following formats

  • OMF 2
  • OpenTL
  • Reaper (rpp)
  • AES31 (adl)
  • XML track archive for Nuendo, Cubase and Studio One
  • Audition 3 (xml)
  • SAW Studio (edl)
  • Samplitude (edl)
  • Tracktion (.tracktion)
  • Ardour (.ardour)
  • Vegas (text edl .txt which Reaper can im/export as well)
  • Presonus (.capture)

More details on the website.

http://www.aatranslator.com.au

ProConvert (indirect session translation tool for Windows and OSX)

ProConvert can produce and read Samplitude EDL and Vegas Text EDL (as can AATranslator) files, which Reaper can natively import and export. It's worth investigating whether or not Samplitude EDL and Vegas Text EDL files can reference interleaved files.


http://www.solid-state-logic.com/post/Pro-Convert/index.asp

Personal tools